Skybot Crashes, and does not interact

Hello all, and thanks in advance for the help!

I have been working on trying to get Skybots for KoA working for a little over 24 hours now. I have read the other threads for this bot, and haven’t found solutions that work for me.

I’m using Nox Player v6.6.1.2, and have downloaded and redownloaded the KOA skybot a couple times. Firewall and antivirus disabled during testing as well. I have finally gotten the bot to “start” while having the game running in Nox, but the bot does not seem to do anything. When I stop the bot, and try restarting it after changing selections, the bot crashes.

Before I even got far enough to get the bot started, Skybot would crash in much the same way as it does now, only it would crash on the FIRST click of “Start Bot”. Process hangs for 3-10 seconds, then force closes with no error messages.

Screenshot of the bot not doing anything included:

I have tried MEmu, but the game does not run in MEmu at all (crashes on startup). Have not tried LD yet but will if anyone really thinks it might work.

Looking forward to meeting the community and hopefully getting to botting for my farm here soon!

Hi Karusai

Thanks for reaching out as well as for the detailed description of the issues you are currently experiencing. It sounds like you have been unable to start the SkyBots application at all? If that indeed is the case, did you happen to receive any errors or the like? In the past, we have had users report issues due to overzealous anti-virus installations, for instance, though it sounds like that might not have been the case for you? In regards to the crashing issues you are currently experiencing, does this happen regardless of which feature(s) you have ticked?

Thanks!

Hey Dev,

The application will start up - I can select KoA Bot and get as far as the screenshot shows. But having the bot script itself actually run seems to be the issue. Unfortunately, no errors seem to come up.
I would assume it is not my anti-virus, as I have confirmed that I shut it off while attempting to run the application.
Crashing issues seem to occur on any combination of feature selections. Originally, it would crash on the first time I clicked “Start Bot”. Now, after downloading SkyBots again, the application would try to run the Bot on first click, but crash if I started it a 2nd time.
It is now about 50/50 on if it crashes the first time or the 2nd time.

Thanks for replying!

Hey @karusai, could you confirm whether or not the bot interacts with the emulator (e.g. does it actually pan to the upper left corner when it logs the action)?

Edit: we’ll have an update out soon

Edit: it’s out!

Sorry for the delay, been a busy few days.
Thanks for getting back to me, devs! I’m downloading the new update now :smile:

Edit: Update works with Nox player - still encounter an occasional crash from SkyBots. SkyBots now successfully interacts with the emulator, and pans the screen and closes interfaces successfully.
However, SkyBots does not seem to actually perform any useful actions.


While it did try to collect food and wood, it did not successfully complete either. When I ticked other options, it got stuck again on “closing interface”.

I still have the issue of the bot crashing if I stop the bot, and then try to start it again (whether or not I change options).

@Epic @rain
Is the KoA Bot updated to use the latest version of KoA? A couple iterations ago KoA updated how the SH looks, by combining all military tents, food, wood, silver, and iron resource buildings into a single building for each type. The strongholds are rearranged from how they used to be, which I think is why when I get the bot to try training troops, it only finds the range and siege workshops and then proceeds to tap in the wrong areas.

Food and wood collection attempts to collect, but misses the tap each time. Does not find silver or iron.

Tribute collection seems broken in general.
I will include a capture of what the updated KoA looks like at the bottom.

Wood, iron, and food visible here
image

Military buildings here
image

Hey again, thanks for the screenshots—the bot is updated to work with the latest version. I just tested on my PC using MEmu and the most recent version of KoA from Google Play and I can’t seem to recreate the issue you are describing. Based on what you are describing, however, it sounds like the emulator window size might somehow affect the internal actions that SkyBots take, have you tried resizing the emulator window such that it is bigger?

i am having the same issue at the original poster. can you tell me how it was fixed?

I am also having the crashing issue as soon as i hit start. But im using the trial vesion to see how it works and if it worked well I am going to purchase it. but i got the free trial and never got a chance to use it because it kepps crashing I assume if it crashes now itll still crash if i puchased it. i would appriciate some assistance in fixing this issue as i am excited to use this bot.

Hi @Jess_Peetz and @James_Mendoza!

Thanks for reporting these issues; we will attempt to recreate them in our development environment and push a fix accordingly. We appreciate your continued patience on the matter.

Thanks!

Do any of you guys who have experienced the crash issue happen to be on x86 machines?